Lock file exists: Collection did not finish update cleanly

Managed by | Updated .

Error message

Displayed in the update-<COLLECTION>.log file

Error: Lock file exists: /opt/funnelback/data/<COLLECTION>/log/<COLLECTION>.lock

Error type

Collection update

Cause

The collection is locked for updating because of one of the conditions:

  • The collection is currently updating.
  • The collection did not finish its previous update cleanly, locking the collection and preventing a subsequent update from occurring.

Resolution

Remove the collection's lock files.

Funnelback 11.0 or newer

From the administration interfacet

From within the administration interface (admin logon required)

  1. Switch to the collection
  2. Select clear locks from the update tab
  3. Restart your collection update from the Admin UI (Update > Update this Collection)

From the Mediator API

  1. Access the following URL (admin UI logon required):

    https://FUNNELBACK-SERVER/search/admin/mediator/ClearLocks?collection=<COLLECTION>
    
  2. Restart your collection update from the Admin UI (Update > Update this Collection)

From the command line

  1. Log in to the Funnelback server (server login required) and run the following command:

    $SEARCH_HOME/bin/mediator.pl ClearLocks collection=<COLLECTION>
    
  2. Restart your collection update from the Admin UI (Update > Update this Collection)

Funnelback 10.1.2 and earlier

From the command line

  1. Delete the following file: $SEARCH_HOME/data//log/update-.lock.
  2. Restart your collection update from the Admin UI (Update > Update this Collection)

NOTE: deleting this file will not clear the update lock on newer versions of Funnelback.

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